Menu

021-26411541Info[at]HoneyTech.ir

بلاگ تِک
01

آموزش فایروال میکروتیک | Mikrotik Firewall



آموزش فایروال میکروتیک | Mikrotik Firewall


فایروال میکروتیک یکی از قسمت های پرکاربرد این روتر می باشد . اگر چه این فایروال کامل نیست ولی می توانید برای حفاظت از خود روتر از آن به شکل گسترده ای استفاده کنید.


میکروتیک هم مانند بیشتر روتر ها به یک فایروال مجهز است . از آنجایی که شرکت میکروتیک همچون بزرگان تولید کننده تجهیزات شبکه دستگاه فایروال مستقل شبکه ندارد . فایروال داخل روتر خود را کمی مجهز تر کرده است هرچند این فایروال به هیچ وجه نمی تواند جایگزین یک UTM و یا فایروال سخت افزاری شود ولی می تواند در پروژه هایی که قیمت تمام شده آن مهم می باشد از آن استفاده کرد.

در ضمن میکروتیک به یک فایروال لایه 7 هم مجهز می باشد که در واقع در لایه Application کار می کند هر چند فایروال لایه 7 میکروتیک هم خیلی کارآمد نیست ولی در بعضی از مواقع کار شما را راه خواهد انداخت.

رول های فایروال بخصوص رول های فایروال لایه 7 ، بار زیادی بر روی پردازنده روتر بورد میکروتیک اعمال خواهد کرد پس دقت داشته باشید در صورتی که تعداد رول های فایروال شما زیاد می باشد و یا به صورت گسترده از فایروال لایه هفت استفاده می کنید در انتخاب روتر بورد مناسب بسیار دقت کنید تا کیفیت سرویس دهی روتر شما پایین نیاید.

برای دسترسی به فایروال میکروتیک از منو سمت چپ ابتدا گزینه IP و سپس Firewall را انتخاب کنید در پنجره باز شده به تب filter role بروید .

فایروال میکروتیک
firewall میکروتیک

تعریف chain در فایروال میکروتیک

فایروال میکروتیک به صورت پیشفرض دارای سه chain می باشد.

  1. Inpute chain منظور بسته های وردی به روتر است . در واقع زمانی که مقصد یک بسته خود روتر باشد این بسته در Input chain قرار دارد . مانند زمانی که از میکروتیک به عنوان DNS سرور استفاده میکنید بسته های DNS در input chain قرار دارند .
  2. Output chain منظور بسته های است که از روتر خارج می شوند . در واقع بسته هایی که آدرس مبدا آنها خود روتر است . مانند بسته ای NTP که روتر به اینترنت ارسال میکند تا ساعت خود را تنظیم کند.
  3. Forward chain منظور بسته هایی است که قصد عبور از روتر را دارند . مانند زمانی که روتر فقط بسته ها را مسیر یابی میکند . و آدرس مبدا و مقصد بسته هیچ یک از آدرس های روتر بورد نمی باشد.

توجه داشته باشید که میکروتیک قابلیت تعریف chain جدید را دارد ولی از آنجایی که آموزش این قسمت در مجموعه MTCNA نمی گنجد در این سری مقالات آموزش میکروتیک به آن نخواهیم پرداخت.

اضافه کرد رول جدید به میکروتیک بسیار ساده است روی علامت add کلیک کرده به تب General می رویم و سپس chain مورد نظر خود را انتخاب و دیگر ، وابسته به سناریو فیلد ها را پر میکنیم دقت کنید که خالی گذاشتن هر فیلد بدان معناست که آن فیلد بی اهمیت می باشد. سپس به تب Action می رویم و نوع عملکرد فایروال با بسته ای که با این رول انطباق پیدا میکند را انتخاب می کنیم .

آموزش فایروال میکروتیک
آموزش firewall میکروتیک

سه مورد از Action های مهم میکروتیک به شرح زیر می باشد :

  1. Accept در واقع این عملکرد اجازه عبور بسته را می دهد .
  2. Drop این عمکرد بسته را دور می اندازد و نتیجه ای به فرستنده ارسال نمی کند .
  3. Reject این عملکرد بسته را دور می اندازند و نتیجه را به فرستنده اعلام می کند .

فایروال میکروتیک هم مانند همه فایروال های دیگر رول ها را از بالا به پایین بررسی می کند و در صورت انطباق بسته با هر یک از رول ها بقیه رول ها نادیده گرفته می شوند .

در winbox با استفاده از Drag & Drop می توانید رول را جابه جا کنید .

برای عملکر بهتر فایروال حتما این سه رول در فایروال با اولویت بالا قرار دهید در غیر اینصورت ممکن است بعضی از رول ها به درستی کار نکنند .
برای اعمال این رول ها کافیست دستورات زیر را در ترمینال میکروتیک کپی کنید .


/ip firewall filter
add chain=forward connection-state=established comment="allow established connections"  
add chain=forward connection-state=related comment="allow related connections"
add chain=forward connection-state=invalid action=drop comment="drop invalid connections" 

آموزش فایروال میکروتیک

مسدود کردن تلگرام توسط فایروال میکروتیک

هر چند فیلترینگ اپلیکشن ها باید در لایه نرم افزار انجام شود ولی در صورتی که تجهیزات لازم برای اینکار را ندارید می توانید از فایروال میکروتیک برای اینکار استفاده کنید .

فرض بر این است که شما به وسیله میکروتیک به کاربرانتان اینترنت میرسانید. برای مسدود کردن تلگرام باید دسترسی کاربرانتان را به چند آدرس IP مسدود کنید .

برای اینکار ابتدا در پنجره فایروال به تب Adresslists می رویم .

فیلتر کردن تلگرام در فایروال میکروتیک

در این قسمت با کلیک روی ADD این سه آدرس IP را با نام دلخواه درج می کنیم.  ( نام برای هر سه آدرس باید یکی باشد )

به عنوان مثال ما در اینجا نام را Telegram قرار می دهیم .

مانند شکل زیر این سه آدرس IP به Addresslist اضافه می شوند .

بستن تلگرام در فایروال
مسدود کردن تلگرام در فایروال میکروتیک

به تب filter rules برمیگردیم و یک رول جدید اضافه می کنیم از آنجایی که این رول باید جلوی بسته های عبوری را بگیرد در تب General فیلد chain را روی Forward قرار می دهیم . به تب Advance می رویم و در قسمت Dst . address list آدرس لیستی که ساخته ایم را اضافه می کنیم .

فیلتر کردن تلگرام در میکروتیک
بستن تلگرام در میکروتیک

سپس به تب Acction می رویم و action را روی Drop یا  Reject قرار می دهیم.

مسدود کردن تلگرام در میکروتیک

در واقع به دلیل خالی گذاشتن فیلد آدرس مبدا عمل فیلترینگ برای همه کلاینت ها انجام می شود.

توجه داشته باشید این روش در زمان نگارش این مطلب کار خواهد کرد ولی ممکن است در آینده با تغییر آدرس IP سرور های پیامرسان تلگرام یا اضافه شدن سرور های جدید این روش پاسخگوی نیاز شما نباشد.



امتیــــاز : Article Rating
تاریــــخ : پنجشنبه, 08 مهر,1395
گروه مطلب : آموزش میکروتیک
به این مطلب امتیاز دهید

نظراتی که قبلا به این مطلب داده شده
Azad
نظر دهنده : Azad پاسخ
تاریـخ ثبت : چهارشنبه, 15 دی,1395 07:51 ب.ظ
با سلام
اگه کسی فیلتر شکن داشته باشه باز هم می تونه وصل بشه به تلگرام ؟ با روش بالا
پاسخ دهنده : محمد یزدی زاده پاسخ
زمان پاسخ : پنجشنبه, 16 دی,1395 10:03 ب.ظ
بله , با توجه به اینکه در اغلب فیلتر شکن ها از سیستم تونلینگ استفاده می شود لذا تمام پکت های ارسالی آن شخص به سمت سرور فیلتر شکن می باشد و با توجه به این که شما در روتر خود dest ip رو چک میکنید ردپایی از سرور های تلگرام مشاهده نخواهد شد و آن فرد به تلگرام متصل خواهد شد .

فرشاد
نظر دهنده : فرشاد پاسخ
تاریـخ ثبت : یکشنبه, 31 اردیبهشت,1396 09:07 ق.ظ
دوست عزیز ممنون از مطلب فوق، حالا اگر بخوایم برای چند IP این محدودیت اعمال نشه باید چه کاری انجام بدیم؟

reza.aghajari
نظر دهنده : reza.aghajari پاسخ
تاریـخ ثبت : جمعه, 21 مهر,1396 11:13 ق.ظ
باسلام
ممنون از پست شما. من به عنوان مسئول آی تی شرکت یکی از مشکلاتی که کاربرام ایجاد میکردن حل شد.

نظر شما در مورد این مطلب چیست ؟

نام

ایمیل

من را از نظرات بعدی از طریق ایمیل آگاه بساز

پاسخ انصراف

x