Menu

021-26411541Info[at]HoneyTech.ir

بلاگ تِک
28

تونل PPTP در میکروتیک



تونل PPTP در میکروتیک


تونل های نقطه به نقطه

تونل های نقطه به نقطه مدلی از تونل هستند که در واقع یک نقطه دسترسی یا VPN سرور در آنها تعریف می شود  و دیگر به تعداد نا محدود میتوانیم کلاینت به آن متصل کنیم در ضمن کلاینت ها لازم نیست یک روتر باشند و در واقع اکثر وسایل شبکه از جمله کامپیوترها ، تلفن های IP ، پرینتر ها و ... معمولا از تعدادی از پروتکل های این نوع تولنیگ پشتیبانی می کنند .

از کاربردهای تونل های PPP می توان به اتصال Site to Site و یا یک Point to site  اشاره کرد به عنوان مثال یکی از کارمندان شما در منزل کار می کند و شما باید بستر ارتباطی آن با شبکه داخلی شرکت را برقرار نمایید. یکی از راه حل های شما استفاده از تونل های PPP است . و از آنجایی که بستر اینترنت یک بستر عمومی می باشد لازم است این بستر امن باشد یعنی اطلاعات به صورت رمز گذاری شده در تونل منتقل شوند. در این سری از مجموعه آموزش میکروتیک تونل های PPTP و L2TP را آموزش خواهیم داد.

تونل PPTP روی میکروتیک

تونل PPTP قدیمترین و محبوب ترین تونل نقطه به نقطه می باشد که تقریبا تمام دستگاه های مبتنی بر شبکه IP از آن پشتیبانی میکنند. تونل PPTP برای کپسوله کردن اطلاعات از GRE استفاده میکند و کانال کنترل آن بر روی TCP می باشد.

PPTP داده ها را با نرخ 128 bit رمزنگاری میکند که جزو ضعیف ترین رمزنگاری ها می باشد.

این نوع رمزنگاری از نگاه شرکتی مثل مایکروسافت بسیار نا امن می باشد .

تمامی فایروال های محبوب این پروتکل را پشتیبانی می کنند. در صورتی که امنیت اطلاعات برای شما اهمیت زیادی ندارد استفاده از PPTP به دلیل نداشتن سربار زیاد بسیار سریع و کارآمد خواهد بود.

راه اندازی تونل PPTP روی میکروتیک

تونل PPTP نیاز به یک سرور دارد. در اینجا سرور ما یک روتر میکروتیک می باشد برای فعال کردن سرور PPTP در میکروتیک  ابتدا از طریق منوی سمت راست Winbox گزینه PPP را انتخاب می کنیم .

تونل PPTP در میکروتیک
آموزش تونل PPTP در میکروتیک

در پنجره باز شده مانند تصور رو دکمه PPTP سرور کلیک کرده تا پنجره ای مانند شکل زیر باز شود در این پنجره کنار Enable تیک میزنیم تا PPTP سرور فعال شود .

سپس باید برای کلاینت هایی که می خواهیم به VPN سرور متصل شوند نام کاربری و رمز عبور بسازیم برای این منظور به تب Secret می رویم نام کاربری و کلمه عبور دلخواه را وارد میکنیم نوع سرویس را بر روی PPTP قرار می دهیم در این مجموعه آموزش میکروتیک از پروفایل پیشفرض میکروتیک استفاده میکنیم برای همین لازم است localAddress و Remote Adress را وارد کنیم Local Adress در واقع IP است که به سر متصل به سرور تونل اختصاص پیدا میکند و Remote Adress به سری که کلاینت هست اختصاص داده می شود می توانیم از دو IP در یک رنج استفاده کنیم به مابقی تنظیمات کاری نداریم و پنجره را تایید میکنیم تنظیمات سمت سرور تمام شده است.

تونل PPP در میکروتیک
آموزش تونلینگ در میکروتیک

در صورتی که بخواهیم از تونل PPTP به صورت Site to site استفاده کنیم لازم است که کلاینت PPTP هم بر روی یک روتر تنظیم شود در این قسمت هم ما از یک روتر میکروتیک استفاده میکنیم در پنجره PPP و در تب Interface روی گزینه ADD کلیک میکنیم و یک اینترفیس از نوع PPTP Clinet اضافه میکنیم .

تونل PPTP در میکروتیک

در تب جنرال یک نام برای آن انتخاب میکنیم و در تب Dial to باید ابتدا آدرس VPN سرور را در قسمت Connect to وارد کنیم سپس نام کاربری که ساخته ایم را نیز وارد میکنیم و پنجره را OK میکنیم و اتصال برقرار خواهد شد.

آموزش تونل PPTP
تونل PPTP

یکی از مزایای استفاده از پروتکل های PPP این است که فقط نیاز به IP استاتیک روی سرور دارید. فراموش نکنید کلاینت ها می توانند به غیر از روتر وسایلی مثل کامپیوتر ، تلفن و .. نیز باشند .

مثالی از تونل PPTP در میکروتیک

در بالا به آموزش تونل PPTP پرداختیم در این قسمت قصد داریم با مثالی کاربردی کمی آن را روشن تر کنیم به سناریوی موجود در شکل زیر دقت کنید در این سناریو قرار است Router 0 که روی یکی از پورت هایش دارای IP ایستا می باشد به عنوان PPTP سرور ایفای نقش کند . Router 1 به عنوان PPTP کلاینت برای ارتباط Site to Site به آن متصل می شود بعد از برقراری تونل PC1 باید بتواند PC2 را ping کند.

PC3 یک کامپیوتر مستقل است که به طریقی به اینترنت متصل شده است (نوع اتصال به اینترنت هیچ اهمیتی ندارد) با راه اندازی PPTP کلاینت روی آن و اتصالش به PPTP سرور ، فعال روی Router 0 در واقع آن هم به شبکه ما متصل و PC 0 و PC 1 را پینگ خواهد داشت .

تونل PPTP در میکروتیک

از آنجایی که مراحل کار را در قسمت قبل توضیح داده ایم در این قسمت از طریق دستورات CLI دستورات را وارد می کنیم . توجه داشته باشید در بیشتر موارد با دنبال کردن مسیر دستورات CLI می توانید منوی آنها رادر Winbox پیدا کنید ولی برای دستورات مربوط به تونل کمی متفاوت است .

ابتدا PPTP سرور را روی Router 0 فعال میکنیم .


/interface pptp-server server set enabled=yes

سپس دو عدد Secret برای اتصال Router 1 و PC 2 می سازیم


/ppp secret add name=router1 password=123456 service=pptp local-address=192.168.200.1 remote-address=192.168.200.2
/ppp secret add name=pc2 password=456789 service=pptp local-address=192.168.200.1 remote-address=192.168.200.3

اگر دقت کنید در هر دو Secret آدرس IP سمت سرور ثابت است .

روی Router 1 هم با دستور زیر یک کلاینت PPTP با متغییر هایی که در Secret تعریف کرده بودیم می سازیم


/interface pptp-client add name=tunnel  user=Home password=123 connect-to=85.158.142.2 disable=n

تا اینجا اتصال تونل برقرار شده و فقط کافی است روی هر روتر یک خط روت اضافه کنیم نا PC 0 و PC 1 یکدیگر را ببنیند

روتر 0


/ip route add dst-address=192.168.70.0 gateway=192.168.200.2

روتر 1


/ip route add dst-address=192.168.40.0 gateway=192.168.200.1

کار تمام شده و ارتباط Site to Site بر قرار است برای اتصال Point to Site هم کافی است یک PPTP clinet روی ویندوز بسازیم این کار در نسخه های مختلف ویندوز متفاوت است . دقت داشته باشید در اتصال Point to Site نیازی به اضافه کردن روت نیست .



امتیــــاز : Article Rating
تاریــــخ : ﺳﻪشنبه, 06 مهر,1395
گروه مطلب : آموزش میکروتیک
به این مطلب امتیاز دهید

نظراتی که قبلا به این مطلب داده شده
Amir Bastan
نظر دهنده : Amir Bastan پاسخ
تاریـخ ثبت : ﺳﻪشنبه, 10 اسفند,1395 12:38 ق.ظ
با سلام و خسته نباشید
من با روش بالا تانل رو ایجاد کردم اما فقط می توانم با ایجاد کانکشن vpn در ویندوز از کامپیوترهای دفتر مرکزی پینگ بگیرم اگر امکانش هست من و راهنمایی کنید لطفا
باتشکر فراوان
پاسخ دهنده : حمیدرضا آروین نژاد پاسخ
زمان پاسخ : ﺳﻪشنبه, 24 اسفند,1395 10:32 ق.ظ
سلام لطف میکنید سناریو خود را بیشتر توضیح بدید

hamed
نظر دهنده : hamed پاسخ
تاریـخ ثبت : جمعه, 26 خرداد,1396 04:12 ب.ظ
سلام. با تشکر فراوان از شما که این مطالب بسیار کار آمد رو در اختیام ما گذاشتین.
تو قسمت pptp متوجه نشدم که تو local address و remote address چی باید قرار بدیم. اگه میشه بیشتر توضیح بدین. تشکر

نظر شما در مورد این مطلب چیست ؟

نام

ایمیل

من را از نظرات بعدی از طریق ایمیل آگاه بساز

پاسخ انصراف

x